PDA

View Full Version : SB P17X Series Support Pack 2.8 (10/25/2012) - AudigySE/Value/LS_Live24bit_X-Fi XtremeAudio_SB5.1VX



daniel_k
10-27-2012, 03:18 AM
This software/driver pack is unofficial, not supported by Creative Labs.

Use it at your own risk.

Supports any model of the following Sound Blaster cards (based on the P7X audio controller):

- Audigy Value
- Audigy SE
- Audigy LS
- Audigy 2 LS
- Live! 24-bit
- SB 5.1 VX, including Rocketfish RF-51SDCD
- X-Fi Xtreme Audio (PCI only), including Rocketfish RF-71SDCD.

Operating systems supported: 32-bit and 64-bit editions of Windows 8 / 7 / Vista SP2 / XP SP3

Included in the pack:

- Drivers for Windows 8 / 7 / Vista v5.12.1.2020 and Windows XP v5.12.01.626
- ALchemy 1.43.27 (Windows 8 / 7 / Vista only)
- Audio Console 3.00.69
- Entertainment Console 3.00.66
- Host OpenAL 1.02.01 (Windows 8 / 7 / Vista only)
- SoundFont Bank Manager 3.21.02 (Windows XP only)
- Volume Panel 2.21.17





Does this driver improve sound quality or performance Are there any tweaks

No, this driver does not improve sound quality nor increase performance.

No, there are no tweaks.

If someone states that its driver improves sound quality and performance, you are being fooled, cheated.

It is even worse that the so called tweaks come from a person who is not EVEN technically acknowledged, does NOT know anything about Windows internals, software engineering and sound fidelity that all audiophiles always look for.

If you "feel" the sound better, that is the infamous placebo effect and there is no real proof that any tweaks work.

In fact, I have yet to see a driver that states in its release notes that it improves sound quality.

I've disassembled about every single .SYS driver, .DLL libraries and .EXE executables and found nothing.

There are some undocumented registry values, but nothing related to sound quality or performance.

Would the so called tweaks even exist, they would be in my Support Packs, you can bet that.





Fixes and improvements:

- Adds Windows 8 support to some setup scripts still not updated by Creative
- Improves Windows 8 support with updated applications and shared components
- Adds Entertainment Console as a faster and lightweight alternative to Console Launcher
- Updates the Windows XP driver
- Fixes Creative SoundFont Synthesizer mute issue on Windows XP/Server2003
- Fixes CrystalizerUnlocker not detecting proper software installed on 32-bit edition of Windows 7 / Vista
- Driver based on WHQL release from WindowsUpdate (with Headphone mode/Bass Redirection fixes by me)
- Fix Console Launcher memory leak and slow loading when running under Windows 7 / Vista
- Updates many shared components for improved compatibility and performance.
- Updates OpenAL redistributable to 2.1.0.0
- Fixes the Headphone mode reseting to Speakers mode on reboot (all cards. including the X-Fi Xtreme Audio)
- Console Launcher is now installed for all cards on all OSes, so Audio Center is removed
- Updates OpenAL redistributable to 2.0.7.0
- Fixes broken uninstaller on all OSes,
- Added Volume Panel by demand.
- Replaces Audio Console to fix multilanguage install.
- Changes setup routine and uses updated scripts.
- Changes application installation to silent mode.
- Enables language selection dialog
- Updates 3D engine filter driver for Windows XP.
- Fixes some issues with device features.
- Improves EAX performance on XP.
- Improves OpenAL compatibility.
- Updates Creative Software Synthesizer (XP only).
- Fixes CMSS not working on Windows 7 for AudigySE/ Value/LS / Li've24bit / SB5.VX, now everything works.





Release Notes:


WINDOWS 8 INSTALLATION STEPS

- Open the Charms bar (press the Windows logo key + C).

- Select Settings -> Change PC Settings -> General

- Scroll down and click on Restart Now (under Advanced startup) and wait.

- Now choose Troubleshoot -> Advanced options -> Startup settings -> Restart.

- When prompted, press the 7 or F7 key to Disable driver signature enforcement.

- Now you can finally proceed with the Support Pack installation.



Windows Security warning during driver installation

When prompted with: "Windows can't verify the publisher of this driver software", choose "Install this driver software anyway".



X-FI Crystalizer is available only for X-Fi Xtreme Audio on Windows 8 / 7 / Vista

Crystalizer is not available for Audigy Value/SE/LS, Live! 24-bit and SB 5.1 VX on Windows 8 / 7 / Vista.



Configuring CMSS on Windows 8 / 7 / Vista

For all supported cards, except the X-Fi Xtreme Audio, Audio Console should be used to configure CMSS, which is not available in Entertainment Console.



Download:

Filename: P7X_SupportPack_2_8.exe
File size: 48.6 MB
CRC32 hash: 48577A03
SHA- hash: 37A5FCDB132E5BF8465439F89DA3745B33352E29

This updated version includes fixes for Windows XP and Windows 8 ONLY.

If you are running Windows 7/Vista with Support Pack 2.6+ already installed, you DO NOT need to install this.

Mirrors: Hotfile (http://hotfile.com/dl/177698956/49e99d0/P17X_SupportPack_2_8.exe)


All files are property of Creative Technology Ltd, except otherwise noted.

squall_leonhart
10-27-2012, 11:44 AM
the VolPanlu.exe in this kit is missing the dts interactive right click item.

Vinay2007
10-27-2012, 02:55 PM
Hi...

I Installed pack on Audigy Value,Entertainment Console Not Working on Win 7x64, going to re-install anyidea...

http://img849.imageshack.us/img849/992/77213513.jpg

daniel_k
10-27-2012, 07:52 PM
the VolPanlu.exe in this kit is missing the dts interactive right click item.

And what is the point of having DTS Interactive working if it is not supported by the P17X series cards?

All apps included are the latest versions that are working properly with the devices supported by this pack and might not work for other devices.

Every pack has its own set of working applications.

Just avoid the use of my customized versions and stick with the public and officially ones and you'll be safe.

daniel_k
10-27-2012, 07:54 PM
Hi...

I Installed pack on Audigy Value,Entertainment Console Not Working on Win 7x64, going to re-install anyidea...

http://img849.imageshack.us/img849/992/77213513.jpg

Oops, packed a pre-final release. Sorry!

Vinay2007
10-27-2012, 09:06 PM
Oops, packed a pre-final release. Sorry!

So May i knw when u release Final Versions...:)

daniel_k
10-27-2012, 10:02 PM
So May i knw when u release Final Versions...:)

Done!

sam2012
10-27-2012, 11:24 PM
Hi Daniel...

Just Downloaded and Installed ur new driver, Works fine, "Crystalizer is not working, it's says Software is Invalid tried in safe mode" I have one doubt, i can't hear Folder Opening Sound, the same with Creative Official drivers, i have tried changing Windows sounds, still not getting Windows Folder opening sounds :(, Anyway Thx "Daniel_k" for ur hardwork......

Im Using Audigy Se on Windows 7x64 Sp1

daniel_k
10-28-2012, 12:31 AM
Hi Daniel...

Just Downloaded and Installed ur new driver, Works fine, "Crystalizer is not working, it's says Software is Invalid tried in safe mode" I have one doubt, i can't hear Folder Opening Sound, the same with Creative Official drivers, i have tried changing Windows sounds, still not getting Windows Folder opening sounds :(, Anyway Thx "Daniel_k" for ur hardwork......

Im Using Audigy Se on Windows 7x64 Sp1

Not sure about the Windows sound effects, nothing I can do, I'm afraid.

Fixed the Crystalizer issue e reuploaded the pack for those who need it.

zalbard
10-28-2012, 08:38 AM
Is there an updated pack for PCI-E X-Fi coming up? Would very much love to see it released. :o
I am personally interested in Auzen X-Fi Forte because it gets no official support.
And thank you for your hard work, Daniel! :)

beclosetolovedale
10-31-2012, 01:01 PM
Wow finally SB P17X Series Support Pack 2.8. Thank you daniel_k

kingleo
11-15-2012, 02:43 PM
DL: Mirror
http://180upload.com/wgvjsl4bxeya
http://filerio.in/nrtm2asspjfw

kamild1996
12-15-2012, 07:06 PM
With these drivers, sound is randomly turning off. To fix it, I have to restart my PC.
Any idea to get rid of that permanently?
When it happens, Creative Audio Control Panel shows no speaker options: http://prntscr.com/m8ktk
Also, DXDiag shows that:
"(DirectSoundCreate): HRESULT = 0x88780032 (error code)"
and foobar2000 shows that:
"Unrecoverable playback error: Unknown error code (0x88780032)"
When I go to "Playback Control" and uncheck "Mute" below the "Microphone" column, I can hear sound from microphone.

jaasmineking
12-17-2012, 01:15 PM
CMSS 3D is not working in windows 8 pro with media center.It worked perfectly in windows 7 64 bit .but not in windows 8.I tried re installing driver and software.but result is not fruitful.Any Suggestions to make it work?very urgent.Thanks in advance

daniel_k
12-17-2012, 07:39 PM
CMSS 3D is not working in windows 8 pro with media center.It worked perfectly in windows 7 64 bit .but not in windows 8.I tried re installing driver and software.but result is not fruitful.Any Suggestions to make it work?very urgent.Thanks in advance

The issue occurs in Media Center only? What about other apps?

Didn't try Media Center personally, but all effects work just fine with any games and music apps.

jaasmineking
12-17-2012, 08:22 PM
No i didn't try in media center.Mostly i won't use it .But the os is with media center i.e i installed windows 8 pro with media center x64 build 9200 .i tried with vlc media player 2.0.4 ,windows media player and others, it plays stereo in front left and right speakers i didn't get 7.1 surround. I installed driver as u mention in the thread by diabling driver signature..only problem is cmss 3d is not working.And i'm having audigy value.Please guide me to fix

jaasmineking
12-18-2012, 03:06 AM
Finally I found solution ..after installing windows 8 pro only it works perfectly.the problem is with the os Windows 8 pro with media center .Thanks to Daniel for his great work.if possible make this work with the Windows 8 pro with media center OS ..

jaasmineking
12-18-2012, 08:11 PM
oops this is not solution. problem persists..may be some third party software causes

Abatap
01-01-2013, 12:55 PM
Hello, Daniel. First of all, thanks for your hard work.

And now about my problem. Lately I tried to install your p17x v2.8 pack for my SB 5.1 VX (SB1070) and driver wouldn't work! Driver loading (both during install and each system startup) would take up to 4 minutes and all I hear is white noise unless I put the volume down to the lowest both in the sytem mixer and music player! What is more funny is that the card is working fine with drivers I download from creative.com. Another funny thing is that a few months ago I was using Live! 24-bit and Audigy SE cards with your v2.7 pack and they worked well, but even earlier than that I tried to use my old SB Live! 5.1 (SB0228) with your Live! support pack and I've faced the same white nose issue white the card was working fine with kX drivers! And all that on exactly same computer with exactly the same Windows install and I do know how to clean up every trace of a driver from registry and system folders. My computer is an old p4 3.0 ghz, 2gb ram, geforce videocard (not sure why would it matter but still) and all that is on asrock P4i65G mobo with Windows XP SP3 x86 installed. Btw I managed to install your driver (without mixers and consoles) on top of the official sb 5.1 vx driver package and it installed okay with no white nose and slow loading times but then I thought that my first attemt on installing was just unlucky somehow so I just deleted everything and tried to install your pack again and I get the same issue just with no white nose but slow loading time is there again! Other than that, your pack works well! So I'm asking if you can give me some tips on how to overcome my issue. I haven't tried v2.7 pack yet btw.

desirer
01-17-2013, 05:11 PM
Hi,
is there any chance to use P17x SSP 2.8 with SB Audigy 2 Value (SB0400)? As far as I know, it uses p17v chip. Couldn't install it using default installer ("no supported device found") nor using W7 device manager ("device cannot start"). Under device manager card is recognized as \VEN_1102&DEV_0008&SUBSYS_10011102, works well with official drivers.

One more thing: in my configuration, the sound quality indeed changes with different sets of drivers. The volume level differs despite the same slider position, the sound is more rich or flat - maybe it depends on bass/treble defaults, also enabling the 24bit mode with some drivers improved the crispness of the sound (2_18_0017), with other had no influence or even decreased it (2_18_0011). And I'm speaking about the official drivers, there may be even more difference with tuned ones. I have rather good 100W HiFi system, and did some "double-blind" tests, so it's definitely not the placebo effect.

Dalky
01-31-2013, 11:27 AM
hello, please help. I uninstalled originals driver, to install new suport pack 2.8 but now I DON'T now how install it, also I have tried reinstall originals driver but I DON'T GET IT

Dalky
01-31-2013, 12:37 PM
hello, please help. I uninstalled originals driver, to install new suport pack 2.8 but now I DON'T now how install it, also I have tried reinstall originals driver but I DON'T GET IT. well after that the solusion was restore the sistem at point early but, I am upset because I don't install suport pack 2.8, I use audigy SE

deeppit
02-28-2013, 09:41 PM
Works Fine Thank You. From Turkey.Creative Sound Blaster Audigy Value - Windows 7 x64. I have an equalizer now :)

tntmarcel
03-19-2013, 04:23 AM
Great job daniel_k, my sound card works wonderful now on win 7. We creative fans owe you much for your hard work! Thanks a lot and good luck in all your present and future projects.

fchioa
05-27-2013, 01:23 PM
I love my sb0410 thanks daniel_k.

herriGalo
11-01-2013, 09:21 AM
Thanks daniel for these excellent drivers, but am having trouble with windows 8.1. The drivers dont work on win 8.1?

SaYmoN
12-07-2013, 04:42 PM
I think i found a soulution for win 8.1 you need to turn off signatures forcing the driver

sorry for my english i know its bad.

1. click windows + R
2. write shutdown.exe /r /o /f /t 00
3. solve problems or something like this...
4. advanced Options
5. restart
6. now we have Advanced Boot Options
7. turn off signatures forcing the driver by pressing key 7

bidomo
01-25-2014, 03:29 AM
Anybody else who thinks it would be a good idea to upload the package to a new host or multiupload?

Ali-S
02-07-2014, 08:41 PM
There will be drivers for windows 8.1 or not ?

Stevolator
02-11-2014, 01:05 AM
Yeah, it would be a great idea. C

deeppit
02-23-2014, 05:58 AM
Here is my download mirror friends (scan after download); http://www.multiupload.nl/2LMQFKSTCD

wollie
03-12-2014, 06:28 PM
Thanks for this pack
wollie

johhbatista
03-26-2014, 10:25 AM
Sorry man, but this driver not install in my windows 7 64bits

johhbatista
03-26-2014, 10:26 AM
anyone can help me? (sorry for my english)