Results 1 to 7 of 7

Thread: 6GB Zen Micro -- problem with firmware upd

  1. #1

    6GB Zen Micro -- problem with firmware update

    I bought a 6 gb zen micro off ebay inexpensi'vely to use as a backup for my Sansa e280, thinking it likely had a firmware issue, judging by the seller's description. The problem I'm running into is the firmware upgrade program keeps insisting that the player isn't connected even though I know bloody well it is connected. I've tried on 2 different machines, one running Win XP, the other Vista, with essentially the same (non)results.

    Here's the deal. The Micro will power up and then randomly do any of the following: go to the recovery screen, freeze up at the Creative logo, or admonish me that my battery is low and go into recharging mode (if connected to the USB port or to a wall charger).

    At the recovery screen all of the options seem to work except for the significant fact that every option appears to hang with the message of either formatting... or scanning... or erasing firmware..., none of which said processes appearing to make much progress. Should I be able to feel the hard dri've vibrating during a format? I can't. If I plug it into a USB port at the recovery screen, the computer makes no response at all.

    At the Creative logo screen if I plug it into the USB port, again the computer makes no response at all.

    At the battery charging screen if I plug it into the USB port I do get a response from the computer. I view this as an encouraging sign, but still the firmware upgrade program blithely insists the device is not connected and that I should bloody well connect the blasted thing forthwith. An intriguing aspect of all this is that occasionally the computer will recognize the device as a portable MPT device and on other, rarer occasions, will see it as a Creative Zen Micro. In both events, however, the operating system cannot load the drivers because of some unspecified failure of the device. My guess is the device driver installation fails because the firmware has been corrupted. The irritating thing is how Windows can see it as a Creative Zen Micro whereas the firmware upgrade program cannot recognize it. I downloaded the MP3 Recovery Tool, which appears to have recognized the device seeing as how it proceeded to download the correct firmware upgrade program.

    I've tried clean booting XP, but it does no good. I've tried plugging directly into the computer, as opposed to using a USB hub device. I even tried rolling back Windows Media Player back to version 9. Any ideas? Could it be a hardware problem? I suspect the battery needs to be replaced, but I'm not planning on shelling out 0 to 5 bucks without knowing for sure I can get the device to work. Could it be the hard disk? I sort of doubt it because I've gotten no hard disk error messages, but that could be because the firmware is also too corrupt to get that far.

  2. #2

    Re: 6GB Zen Micro -- problem with firmware update

    An update for those who might have been playing along at home. I found the thread relating to fixup.zip, downgraded to WMP 0.0 (so fixup.cmd would find the version of WMP it was designed to work with), and managed to get the MTP driver properly installed for the device. It even shows up in Device Manager as a Creative Zen Micro with no yellow exclamation marks to be found, and with a clean bill of health from Windows to the effect that the device is "working properly", which, of course, it is not.

    Curiously, however, the firmware upgrade program, instead of adamantly insisting the device is not connected started simply freezing up or at least appearing to freeze up. One of the other programs I downloaded from the Creative website also freezes up while attempting to find the device. Before, these programs would instantly say the device wasn't connected, but now they appear to hang up. I say "appear" because sometimes after some internal timeout period perhaps, they would return to life and again insist the device is not connected.

    One more note: when I plug in the device the familiar screen pops up asking if I want to view the files on the device with Windows Explorer, do I want to sync up with Windows Media Player, or do I want to take no action. If I try Windows Explorer, the little flashlight keeps on searching through the folder. If I try to sync with WMP, then WMP searches and searches for the device. If I try to bring up My Computer, the main page where all the dri'ves and devices are listed, I get the same flashlight search. If I unplug the device, then all the programs that appear to have frozen instantly come back to life and tell me the device is not connected.

    Since then I've upgraded back to WMP , which has only served to make things worse. Now the MTP driver refuses to properly load. I get the yellow exclamation point in Device Manager. I just finished downloading and updating my system BIOS to the latest version. I suppose my next step will be to downgrade back to WMP 0.0 again since that seems to have been the closest I've come to success.

  3. #3
    Contributor
    Join Date
    Jan 2008
    Posts
    21

    Re: 6GB Zen Micro -- problem with firmware update

    http://uk.europe.creative.com/suppor...p?l=3&sid=9287?try this link I had the same problem

  4. #4

    Re: 6GB Zen Micro -- problem with firmware update

    Thank you for the link. I had already tried that one, but I went ahead and tried it again. It still doesn't allow me to upgrade the firmware. In fact, upgrading back to WMP has made matters worse because now the Device Manager icon always has the exclamation point and it shows up as a generic MTP device whereas at least with WMP 0 it shows up as a Creative Zen Micro without any exclamation points. It keeps finding the device over and over again and telling me to restart over and over again. Something in WMP keeps the MTP driver from properly installing I guess.

    My motherboard has the VIA USB Controller. I read somewhere the VIA controllers don't work well with the Zen Micro. I have an IOGEAR USB PCI card that I had bought for another computer a long time ago, but it has the ALi chipset, which I understand also has known issues with the Zen. Nevertheless, I tried to install it in my machine just to see, but can't get the drivers to install for that board -- keep getting blue stop screens.

  5. #5

    Re: 6GB Zen Micro -- problem with firmware update

    I had exactly the same problem with my Zen Micro 6Gb DAP-MD0004 v0.0.58.

    I tried on two different XP (home and professional, both up to date with latest patches) and one win2k box with two firmware update utilities for .x and 2.x firmware. All say that player is not connected, while it shows up in Device Manager similar to
    http://ask.europe.creative.com/wweng...e_check_dm.png.
    The device shows up as "Creative Zen Micro" with USB vendor and product ids as VID_04E/PID_430.

    At the same time Windows Media Player on XP can properly sync music with my player.
    I also tried installing Creative MediaSource PlayForSure and normal versions. None detected the connected player.

    The solution appeared to be very simple. The firmware 2.x upgrade utility works only on XP SP or newer with Windows Media Player 0. It does not work with Windows Media Player . To avoid messing around with the downgrade from to 0 I found a relati'vely clean XP installation with Windows Media Player 9 still on it.
    Installed Windows Media Player 0 from http://www.microsoft.com/windows/win...0/default.aspx and firmware upgrade went without a single hitch!Message Edited by ybk on 0--200807:00 PM

  6. #6

    Re: 6GB Zen Micro -- problem with firmware update

    I found a program called fwupgrade.c as a sample in the libnjb package at http://libnjb.sourceforge.net/. fwupgrade is supposed to extract the actual firmware image from the creative firmware upgrade program and use that firmware image to flash the device. Unfortunately, (or maybe fortunately since this could possibly wreck the player) fwupgrade doesn't support MTP devices and my Zen Micro is in MTP mode. Since I can't get the device to boot up there's no way to switch it into what Sandisk calls MSC mode (for mass storage devices). I don't even know if this particular Zen Micro supports any mode other than MTP mode.

    fwupgrade does find the device as idVendor = 0x4e / idProduct = 0x430. Likewise, the test program that comes with libusb-win32 also finds the device with the same vendor and product id. The Zen Micro version that fwupgrade supports has idVendor = 0x4e / idProduct = 0x4e. (apparently a non-MTP mode version of the Zen Micro?) I bring up all of this because my Sandisk e280 has 2 usb modes: MTP and MSC. In order to upgrade the firmware on the e280 it has to be in MSC mode. I'm wondering if the Zen Micro has to be in another mode aside from MTP in order for the firmware upgrade program to find it's

    In Recovery Mode, the device is listed as Creative Zen Micro v0.0.65. All of the options in Recovery Mode seem to hang up except for the reboot option. The other options just say formatting..., or scanning..., or erasing firmware... Does the erasing firmware process have to successfully complete before the firmware can be updated or will the firmware update program still work?

  7. #7

    Re: 6GB Zen Micro -- problem with firmware update

    I downloaded the Microsoft Windows Media Format 9.5 SDK, which provides a few test programs for MTP devices. The test program I used finds the Zen Micro and opens it, but all other tests fail. I suspect the Firmware Update Programs from Creative are also able to find the device and open it, but then fail to do the firmware upgrade. They all simply say they can't find the device or I need to connect the device, but there is a period of many seconds in which the firmware update programs seem to hang and become unresponsi've.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •