Page 1 of 10 1 2 3 ... LastLast
Results 1 to 10 of 98

Thread: Enable DD-DTS decoding on not support cards with latest driv

  1. #1
    Regular Contributor
    Join Date
    Nov 2005
    Posts
    46

    Enable DD-DTS decoding on not support cards with latest drivers

    Hello all,
    Latest creative drivers (2.8.0004) has enabled DD-DTS hardware decoding on certain X-Fi cards however I was able to enable it on my X-Fi Elite Pro SB055A with Vista 64-bit SP by using this set of hacked dat files : http://vbkesha.prgr.org/2_8_0004(X-Fi_DD_DTS_FIX).rar

    So I though I just share my success with you.

    EDIT : For vista, service pack must be installed (Thanks VBKesha)
    UPDATE: Just bought a set of logitech Z5500 digital speakers and I was able to send SPDIF streams directly to them under vista. So spdif passthough is working too.
    Last edited by KokChoy; 11-17-2011 at 10:29 AM.

  2. #2
    Trusted Contributor
    Join Date
    Jun 2005
    Location
    Denmark
    Posts
    151

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    Thanks for the heads up amirali_esh! :-)

    I haven't really investigated, but thought the limitation to be hardware related(as in, an onboard chip was missing in order to save money) but maybe it was "just" a Dolby software license fee Creative where trying to save...

    Have you already verified the dat files works Not as in the option to enable decoding is available, but as in you have tried decoding audio in a movie :-)

    Also, can you provide a translation of the provided readme.txt file My russian is a little rusty! ;-)

    But thanks again for your input!
    Last edited by KokChoy; 11-17-2011 at 10:29 AM.

  3. #3
    Regular Contributor
    Join Date
    Nov 2005
    Posts
    46

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    I don't understand russian either however you can see a translated version of the russian page here :

    http://translate.google.com/translate?&u=http%3A//vbkesha.prgr.org/.

    It is mentioned in the webpage that this only works on windows XP however it worked on vista for me. Here is what I did : I installed x-fi driver 2.8.0004, rebooted installed console launcher 2.60.27 rebooted again then I copied hacked dat files to C:\Windows\System32\data and rebooted one more time. Then I launched Audio console and see that decoder tab is there now, I selected use built-in decoder and then I launched media player classic changed default audio device from default value which was System Default to SPDIF-Out then I tried playing an xvid movie with ac3 sound and selected spdif out in ac3 filter and bingo I can hear the sound. I also noticed that after enabling this hack Dolby and DTS icons appeared on console launcher too. I am using Vista x64 with SP and all latest hotfixes installed and my X-Fi is Elite Pro model SB055A. I hope this information could help you make it work on yours too and sorry for my bad english as it is not my native language.
    Last edited by KokChoy; 11-17-2011 at 10:29 AM.

  4. #4
    Top Contributor
    Join Date
    Sep 2005
    Posts
    708

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    amirali_esh :

    Can you please post a screen shot of the Audio console and the main console where you see the Dolby and DTS icons.

  5. #5
    Regular Contributor
    Join Date
    Nov 2005
    Posts
    46

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    Yeah sure I will do it this evening when I get home from work.

  6. #6
    Top Contributor
    Join Date
    Sep 2005
    Posts
    708

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    at amirali_esh :

    Thanks! It will explain alot by the images and help other people here.

    I can't wait to see

  7. #7
    Trusted Contributor
    Join Date
    Jun 2005
    Location
    Denmark
    Posts
    151

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    Ok I thought you perhaps was russian, heh! ;-)

    Not that it mattered much to me, as the path to which to copy is not in russian, just thought it would be nice to know the details.

    I have copied the CTP055AW.DAT file to the DATA folder(the other files are for other X-FI models I gather) and rebooted and correctly so, the menu option for DD/DTS are now available in the audio consol plus volume panel mixer mode.

    However, it didn't seem to do anything else for me....PowerDVD is silent when SPDIF is choosen and MPClassic gives an error about missing codec or filther when SPDIF output is choosen. If choosing default output and in ac3 filter choose spdif output, I get noise...

    So, currently it doesn't seem to work for me, only add the menu options!

    Are you 00% positi've the audio you got was X-FI decoded I remember seeing a pop-up message appear everytime when Creative's hardware was decoding the audio stream, when I had it working under Windows XP with my older X-FI Elite Pro card.

    Edit: And yes I didn't forget to enable "SPDIF in-decode" or use the "internal decoding" options! ;-)
    Edit2: This was all done in a Vista Ultimate 64 bit enviroment....XP seems to work fine with the workaround!!
    Last edited by KokChoy; 11-17-2011 at 10:30 AM.

  8. #8
    Regular Contributor
    Join Date
    Nov 2005
    Posts
    46

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    Hello again people, sorry for the delay. Here is the screenshot I promised :

    ?http://i35.tinypic.com/36u3jl.jpg

    Please note that my desktop resolution is 900x200 so you might need to scroll the image to view it all in lower resolutions.

    Mr_DJ for PowerDVD you also need to go to control panel->sound and set SPDIF-Out as the default output device. For media player classic it is not necessary since you can select output device via options menu of mpc as you can see in the screenshot.

    And no I didn't get an OSD message like windows xp however I am pretty certain that X-Fi is decoding the stream.
    Last edited by KokChoy; 11-17-2011 at 10:30 AM.

  9. #9
    Trusted Contributor
    Join Date
    Jun 2005
    Location
    Denmark
    Posts
    151

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    Hi again amerali_esh,

    I'm using an dual boot setup and tried the same trick on the XP installation and here it worked without any issues!

    Did fool around with the SPDIF-Out enabled as default under Vista, but not sure in which order I tried the diff. setttings....will try some more Vista testing later!

    However, I guess we can already now conclude, it's not a "missing hardware chip" related feature! :-)

    But cheers for your efforts and letting me know there is a workaround.

    I wonder what Creative feels about our efforts in here however! :-) But seeing there already has been an creative representati've by and not deleting the thread or anything, I guess we are not stepping on any corporate's toes....yet, heh! :-)
    Last edited by KokChoy; 11-17-2011 at 10:30 AM.

  10. #10
    Regular Contributor
    Join Date
    Nov 2005
    Posts
    46

    Re: Enable DD-DTS decoding on not support cards with latest drivers

    Glad to hear you made it work on XP now I know that it is not a hardware limitation however I think creative will disable it on a later driver release when they find out about this hack so let's enjoy it while it is still working. I am really looking forward for an official comment from creative staff on this thread.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •