Page 5 of 5 FirstFirst ... 3 4 5
Results 41 to 48 of 48

Thread: Won't turn on

  1. #41

    Re: Won't turn onZ

    Stemmlerd,
    you need to get a new one, mine was the same until it was replaced

  2. #42

    Re: Won't turn on

    ?
    Get a new one? Maybe.
    Customer support from Creative labs suggested the Troubleshooting Guide. That was silly. It had four suggestions and none of them addressed the problem.
    Next they suggested a rehabbed Vado. After searching the Web site, I cannot find any rehabbed Vados.
    Finally, they said to buy a new one. I cannot find any of those on the site either.

    They gave me a runaround that merely wasted my time. I have to wonder if the Vado is sharing the same fate as the Flip and disappeared.
    I have to wonder if buying a new one from this company is a good idea.
    If anyone can find the link on Creative's web site that will find a rehabbed Vado or a new one, please send it to this forum. They still have a picture of one, but the link goes nowhere.

  3. #43

    Re: Won't turn on?

    Folow up to my previous post:
    I just received an email from Creative. They said that Vodo pocket cams are "currently unavailable." Makes you wonder.
    In just a few hours, they told me to buy a new one from their site and then they tell me they are unavailable.
    Would anyone want to buy a product from this company.
    My Vado lasted less than 2 years.

  4. #44
    Whiz Kid
    Join Date
    Dec 2007
    Posts
    5,276

    Re: Won't turn on

    @stemmlerd?,


    The warranty of a Vado pocket camera is year. This product have since moved on to the 3rd generation, you can find refurbished ones on Amazon.

  5. #45

    Re: Won't turn on

    ?I am aware that the warranty is only for?a year. That was not an issue. The issue is that the device does not turn on unless I plug it into a USB port. Several other people are having the same problem, some of them right out of the box. Obviously Creative Labs is aware of this problem but is offering no information on solving the problem.
    The correspondence from Creative gave me links to Creative's web site for the refurbs and the new camcorders. Later I was told they were unavailable from Creative Labs's Web site.
    I went to Amazon as you suggest and read more customer reviews. There were several reviews from people who said that their Vado would not turn on. Sounds very familiar.
    The Vado is a nice product, very satisfactory, but only when it can turn on.
    Can you tell me unequivocally that Creative is still making this product, or is it an orphan with no support?

  6. #46
    Whiz Kid
    Join Date
    Dec 2007
    Posts
    5,276

    Re: Won't turn on?

    @stemmlerd?,


    Sorry I am afraid I am not much help about this matter. I would suggest that you take this up with support to see what else they have to say.

  7. #47

    Re: Won't turn on

    Just received my Vado HD 2nd Gen from the bundle sale. It won't power on, although it does boot up to live video briefly when I connect it to USB. I've tried two different batteries, but I get the same response whether there is a battery in it or not-- splash screen, brief video, then the USB charging screen, which goes green/fully charged after a couple of seconds.

    Thanks for all the suggestions in the five pages of this forum. Unfortunately, none of them worked, not even upgrading the firmware to the 2010 version, which gave me a success screen but appears to have only changed files in the Movie Creator directory. So far the only thing the Vado does successfully is function as a USB flash drive.

    I have tried the battery in every position possible, including ways that obviously won't work. The battery packaged with the camcorder has some corrosion on the terminals, but the additional one from the bundle looks fine, if a little bigger. I tried pushing the battery up to get better contact but no response. Tried double clicking, clicking and holding, clicking while hooked up to USB, with battery and without. Still doesn't power on.

    Does anyone have any other suggestions?

    I checked Amazon fulfillment, which will only refund my money, not send me a replacement. Waiting for response from Creative support. I would really like to have a working camera, but have already wasted several hours trying to get this one to work.

    Wondering what to do with all the bundle stuff, most of which is useless if the camcorder doesn't work.

  8. #48

    Re: Won't turn on

    Quote Originally Posted by kimiye View Post
    Just received my Vado HD 2nd Gen from the bundle sale. It won't power on, although it does boot up to live video briefly when I connect it to USB. I've tried two different batteries, but I get the same response whether there is a battery in it or not-- splash screen, brief video, then the USB charging screen, which goes green/fully charged after a couple of seconds....

    Does anyone have any other suggestions?
    After one year and one month, my Vado HD displayed all of these same symptoms. Turns out it was a dead battery. I know you said you tried two different batteries, but are you sure either of them were any good? I bought a new one from ebay for $5.19 from this seller: http://myworld.ebay.com/multi-functi...id=p4340.l2559

    It's a standard Digital Camera Battery Fugi NP-60 or Casio NP-30 with the following specs:
    Battery Type: Li-ion
    Voltage: 3.7V
    Capacity: 1050mAh
    Dimension: 1.38" x 2.08" x 0.28"
    The actual auction link (which will expire in 90 days) is here: http://www.ebay.com/itm/220922513135...84.m1423.l2648

    When I received it and popped it into the camera, it started charging immediately, and within an hour my camera was working perfectly again when disconnected from USB power.

    YMMV,
    TT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •