Results 1 to 4 of 4

Thread: **SOLUTION** DLLML.exe Fails to load at startup (application error)

  1. #1

    C**SOLUTION** DLLML.exe Fails to load at startup (application error)^

    Hello everyone!

    I purchased the SB X-Fi Fatalty Champion Edition soon after release, and think this is the best card I have ever used to date. Absolutely love it, unbelievable sound.

    Now a year or two ago I noticed a certain file failing to load when I started windows.

    This file, DLLML.exe. To my understanding this file is used to load EAX emulation support into older games/modules (essential loads a "middle-man" file between the game's sound files/.dll's, and the hardware SPU [Sound Processing Unit, not a real acronym, but that's what I call it since GPU and CPU are similar distincti've acronyms so if you see it used anywhere, it came from me ] to allow EAX support in non-EAX enabled games), and/or to add EAX effects in your audio files using the Wave Studio app.

    I've pinpointed this issue to either a Windows Update, or the Creative auto-update (which could mean it is an error caused by an installaion combination of multiple apps at once) because this issue did not arise until I did these two things (did Windows Update, then Creative Auto-Update, then restarted computer).

    Now I've primarily had this issue with Windows XP x64 but I have had this issue at times with Windows XP x86 as well.

    After you install the software suite, it adds an entry in your Windows Startup to load the module (Start/Run. msconfig. Startup tab. Look for STARTUP ITEM: DLLML). The entry looks like this:
    WinXPx86 looks like: "C:\Program Files\Creative\Shared Files\Module Loader\DLLML.exe" RCSystem * -Startup
    WinXPx64 looks like: "C:\Program Files (x86)\Creative\Shared Files\Module Loader\DLLML.exe" RCSystem * -Startup
    Under most circumstances this module loads fine, but because Creative, for reasons why I have not delved into, loads some of their DLL files differently than the Windows standard, which may also be a cause of this issue (extremely unlikely, I believe it is one of the 2 things i mentioned above).
    Either way, after I did those 2 things, the DLLML.exe startup entry failed to load every time.
    But I fixed it.

    Now what you have to do to resolve this issue, involves editing the startup entry in the Windows Registry.
    If you are scared to go into it, have no idea what I am talking about, or never edited the Registry before, don't worry. If you follow these steps EXACTLY, you have nothing to fear.
    I will be using default installation parameters for file pathing, so if your Operating System is installed in a different dri've letter other than C:\, then just change the letter to the one your OS is installed onto.

    Capitals used for emphesis on actions to take:
    -Hit the START button, then select RUN
    --------If RUN is not in your start menu, you need to enable it by right-clicking and open area of your TASKBAR, select PROPERTIES. --------Click the START MENU tab, then the CUSTOMIZE button. Click the ADVANCED tab. In the START MENU ITEMS box, scroll down to the entry that says SHOW RUN. Check the checkbox to fill it. Then OK/APPLY/OK, and you should be back to the desktop. Then go to START/RUN
    -type the word REGEDIT
    --------This opens the Windows Registry.
    --------DO NOT change ANYTHING in this other than the exact directions I specify or you may corrupt your registry or even worse, corrupt your system, which means F&R time (Format & Reinstall). Treat it like a stripper. You can look all you want but don't touch or there could be dire consequences.
    --------Now the fastest way to find this is to manually navigate to the specific "key" or "entry" you need to modify. Mouse-click the +'s to navitage further into the "hi've" following these maps:
    -FOR WINDOWS XP x86 USERS NAVIGATE TO: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run
    -FOR WINDOWS XP x64 USERS NAVITAGE TO: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432\Microsoft\Wind ows\CurrentVersion\Run
    --------Now you are looking for a specific entry NAME called RCSYSTEM. Depending on which version you are running. They are:
    -FOR WINDOWS XP x86 USERS: "C:\Program Files\Creative\Shared Files\Module Loader\DLLML.exe" RCSystem * -Startup
    -FOR WINDOWS XP x64 USERS: "C:\Program Files (x86)\Creative\Shared Files\Module Loader\DLLML.exe" RCSystem * -Startup
    -------Now we are going to edit the entry. What we need to do is get rid of that * (asterix) character in the name. I don't know why it is there, I'm thinking it may be a coding error. But in my WinXPx64, this was the culprit.
    -Double-click the RCSYSTEM key to edit it, and edit it so it looks EXACTLY LIKE THIS (If you're paranoid about doing something bad, COPY and PASTE this line pertaining to your installed OS. KEEP IN MIND THE INSTALLATION DRIVE LETTER, CHANGE FIRST LETTER IF NESCESSARY)
    -FOR WINDOWS XP x86 USERS: "C:\Program Files\Creative\Shared Files\Module Loader\DLLML.exe" RCSystem -Startup
    -FOR WINDOWS XP x64 USERS: "C:\Program Files (x86)\Creative\Shared Files\Module Loader\DLLML.exe" RCSystem -Startup
    -click OK button. Now it is changed.
    -------And we're DONE EDITING the Registry entry!
    -now go to FILE in the top-left menu, then select EXIT
    -RESTART your computer
    -------You should not receive the "DLLML.exe failed to load" (application error) again!!

    To check to see if it loaded into your system properly (as if not getting the error message anymore was proof enough it loaded properly), when you reboot back to the desktop, do the "three-fingered salute" (ctrl-alt-delete), then select the PROCESSES tab. Click on the IMAGE NAME heading to sort it alphabetically, and look for the name (WinXPx86) DLLML.exe or (WinXPx64) DLLML.exe *32.
    If you see it listed, it loaded!! CONGRATS, IT BE FIXED!!

    If this did not work for you, then your system is posessed, get a priest. I don't think a witchdoctor would give your comp good vibes O_o

    Hope this resolved it for you. Enjoy your EAX with Duke Nukem 3d again!

    EDIT: As a side note, I also noticed that since after this fix, my computer doesn't hang after sending the restart/shutdown killsignal, so I am wondering with people having similar hanging issues, if their issue could be resolved something similar to this.
    Just a thought for any admins/mods/users out there that know what they are doing that maybe wanna test that out.

    Sincerely,
    Jason Ostapyk
    3yr degree, MCP, CCNA, A+ certified, Specialised Electrician Class M Licensed

  2. #2

    Re: **SOLUTION** DLLML.exe Fails to load at startup (application error)?

    G Kudos for a brilliant finding! After a Windows Hotfix on my XP SP3, when shutting down my PC I would wait for a program and then get an error that EAX was not responding before finally shutting down. On next reboot I lost sound on my PC. After running tests, the Direct Sound test failed pointing at EAX.

    This solution cured the problem. Again, kudos, job really well done!!!

  3. #3

    Re: **SOLUTION** DLLML.exe Fails to load at startup (application error)3

    G Thankyou for the kind words, glad it worked for you (and others who have e-mailed me letting me know it worked for you as well).

    *bump*
    For those still having this issue.
    For me it seemed to cure the driver hang problem on the 2.8.003 driver for the most part as well.

  4. #4

    Re: **SOLUTION** DLLML.exe Fails to load at startup (application error)

    jib-jab

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •