Results 1 to 2 of 2

Thread: X-fi titanium recognized by windows but not by cretive control panel

  1. #1

    X-fi titanium recognized by windows but not by cretive control panel

    DX-fi titanium recognized by windows but not by creti've control panelk Hello.

    I have installed a creative X-Fi titanium (regular, not fatality) on my windows 7 machine
    I installed the latest dirvers ( XFTI_PCDRV_LB_2_7_0007 )

    The system seems to recognize the sound blaster alright (it's listed as "Creative SB X-Fi" in the device manager)
    Sound is coming out of the card alright (at least the optical out, which is the one I have linked to my Sound system)

    But, when I try to launch the Creative control panel, it says the supported audio device is not detected on?my system - the application will close (free translation from the french)

    Is anyone able to help me with this problem ?
    I'd be most grateful.

    Take care,
    sykurmoli

    * to be00% accurate, it's initailising strangely. When sound first comes out of the card, my audio system (amp) does not detect it. I have ton manually change the source (to CD for example), then go back to the "optical in" entry (on the sound system) and only?then does my system detect the sound that comes out of the card.

  2. #2

    IwRe: X-fi titanium recognized by windows but not by cretive control panelk

    OK. I don't know how but I solved this. But I have other problems as well ( (see other topic)
    Last edited by Colin-XCL-; 11-22-2011 at 01:15 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •