Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22

Thread: Sound Blaster World of Warcraft Wireless Headset (PC)

  1. #1

    5Sound Blaster World of Warcraft Wireless Headset (PC)H

    hello,

    Today I have received my new headset, and connect to the PC these worked without problems, for some reason decided to update the drivers and firmware for the headphones, and after doing that, now it does not work, turn on, but no sound.

    Any solution?



    there a way to return to the previous firmware?


    Regards
    Last edited by KokChoy; 10-29-2011 at 08:21 PM.

  2. #2
    Super Guru
    Join Date
    Aug 2008
    Posts
    1,964

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)?

    Be sure to go back to your Windows Control Panel and Sound and reselect the WoW headset as default sound device.
    Last edited by KokChoy; 10-29-2011 at 08:21 PM.

  3. #3

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)B

    I am also having the same issue with the firmware upgrade and want to go back to factory firmware. It worked just fine untill I upgraded to the latest firmware driver from the Creative site. You guys should revisit that driver and either fix it or remove it from the site, in my opinion. Now it wont connect at all, the mic doesnt work, the sound doesnt work...nothing. It shows up as usual in the sound options and device manager in Win 7 64bit, you can select both the phones and mic but it doesnt do any good to select them. I must have done it 100 times, every different combo, and I have other items that work just fine so its NOT windows causing it.

    Please put up a link for the original firmware so others and myself can roll back and hopefully start using these VERY EXPENSIVE headphones again.
    Last edited by KokChoy; 10-29-2011 at 08:21 PM.

  4. #4
    Super Guru
    Join Date
    Aug 2008
    Posts
    1,964

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)%

    I am assuming you successfully completed the firmware upgrade? No errors? What I did was upgrade the firmware and reboot. I uninstalled all Creative WoW software and removed the USB stick and rebooted. I checked that my standalone sound card now works fine. Then I reinstalled the newest WoW software. It has been updated since release in early March. I had a March 6th version. The version of the software now is listed as March 23rd compilation date. I reinstalled that and it worked much better for me.
    Last edited by KokChoy; 10-29-2011 at 08:21 PM.

  5. #5

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)?

    Hi There,

    I had the same problem, to fix this, hold down the connect button on the USB Transmitter Stick while your headset is searching for a connection. If that doesn't work hold down the connect button on the headset for about 5 seconds after you've already held down the USB Transmitter stick button and the blue arrow led starts bilking quickly. It should work then.

    Cheers,

    Teksage
    Last edited by KokChoy; 10-29-2011 at 08:21 PM.

  6. #6

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)B

    You did reconnect your headset to the transmitter right?
    Last edited by KokChoy; 10-29-2011 at 08:22 PM.

  7. #7

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)?

    im having a similar problem my headphones work but mic does not. nothing is muted all sounds are turned up lights wont turn on on headset either.
    any help or advice plz would really appreciate
    Last edited by KokChoy; 10-29-2011 at 08:22 PM.

  8. #8

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)?

    I also am unable to pair my headset with the USB transmitter after upgrading to the latest firmware. I have tried all the suggestions here, but I have been unsuccessful. Has anyone received a response from the creative support people? I cannot log a ticket, because I dont have a record of the serial number - anyone know of a utility which will query the device for its number?

    thanks
    Last edited by KokChoy; 10-29-2011 at 08:22 PM.

  9. #9
    Contributor
    Join Date
    Jan 2005
    Posts
    25

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)d

    Ok presuming you have gone through all of these steps. What is your Operating System. Give me that and I will provide some reccomendations.

    For everyone asking for help for this headset. Give me an OS to run with and I will attempt to assist. I am not a Creative Labs rep. But have been in IT support for over 14 years.
    Last edited by KokChoy; 10-29-2011 at 08:22 PM.

  10. #10

    Re: Sound Blaster World of Warcraft Wireless Headset (PC)>

    I turned on my pc tonight and the mic wasn't working. The lights on the side of the headphones are not on as well.

    I upgraded the firmware (SBWH_PCFW_US_1_10_100326), re-paired my device. Sound in the headset works, but my mic and lights are still not working. Has anyone come through with a fix?
    Last edited by KokChoy; 10-29-2011 at 08:22 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •