Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: I will never buy EMU products again

  1. #1

    I will never buy EMU products again

    Hi, I have an EMU 0404 USB, this soundcard is great, very good quality, but unusable because EMU does not let you download drivers online. I don't know why, but it's very annoying because I've lost the CD driver, and I can't do anything, no using, no selling (impossible to sell a card if drivers are impossible to find).

    So if the EMU support is as bad on all products, then I will never buy other product from EMU.


  2. #2
    Uber Guru
    Join Date
    Mar 2005
    Posts
    3,887

    Re: I will never buy EMU products again

    You're lazy reader I quess. Didn't these links help you?

    [url=http://forums.creative.com/t5/E-MU-Creative-Professional/emu-0404-usb-where-s-the-driver/td-p/586301">http://forums.creative.com/t5/E-MU-Creative-Professional/emu-0404-usb-where-s-the-driver/td-p/586301[/url]


    jutapa


  3. #3

    Re: I will never buy EMU products again

    Lazy???? Lol, I've research all over the web, and I can't found any driver. The link you give doesn't give solution. the link http://support.creative.com/kb/ShowA...95146&h=13 doesn't give any acces to a driver link. and the link driver on http://drivers.softpedia.com/get/FIR...mware-13.shtml is a reditrection to the Creatuve support whivh nothing !!!!!

    If I'm lazy, try to found just one link that works or a driver that works, not a beta driver limited in time. It's impossible.I have past many hours to try to find these stupids drivers. Emu wants to sell new products? Sorry, I will not buy them, I prefer to spend my money on hardware with a real support. I have an old RME, more than 10 years past, and it's easy to download the drivers. Not EMU for a product not so old !

    Creative support is **bleep** ! Prove me I'm wrong.
    Last edited by Colin-CL; 11-29-2011 at 03:38 PM.

  4. #4
    Uber Guru
    Join Date
    Mar 2005
    Posts
    3,887

    Re: I will never buy EMU products again

    julien_b wrote:
    Lazy???? Lol, I've research all over the web, and I can't found any driver. The link you give doesn't give solution. the link http://support.creative.com/kb/ShowA...95146&h=13 doesn't give any acces to a driver link. and the link driver on http://drivers.softpedia.com/get/FIR...mware-13.shtml is a reditrection to the Creatuve support whivh nothing !!!!!

    If I'm lazy, try to found just one link that works or a driver that works, not a beta driver limited in time. It's impossible.I have past many hours to try to find these stupids drivers. Emu wants to sell new products? Sorry, I will not buy them, I prefer to spend my money on hardware with a real support. I have an old RME, more than 10 years past, and it's easy to download the drivers. Not EMU for a product not so old !

    Creative support is **bleep** ! Prove me I'm wrong.
    Did you even try ?

    There's a driver + controlpanel in that .zip you get by clicking the link in row:

    0404 USB Beta Driver available

    This beta driver works well upto Windows 8 (32/64 bit) ... I have it in use in Windows 7 32-bit and WIndows 8 64-bit (W8 is Developers Preview version).

    Sorry 'bout the softpedia link, it worked few weeks ago so it might been changed after that.

    jutapa
    Last edited by Colin-CL; 11-29-2011 at 03:35 PM.

  5. #5

    Re: I will never buy EMU products again

    Hello,

    I'm also user of a 0404USB device. I can't find any drivers as well, this link above doesn't work. Please help me and give info where can I find drivers for Vista 32.

    Thanks,
    Sławek

  6. #6

    Re: I will never buy EMU products again

    the correct link for the driver is : http://connect.creativelabs.com/emu/...40_00_beta.zip

    jutapa, thank you, the driver works on my WIN XP PC. I don't know how you find this link, but i never found it on google with keywords EMU 0404 USB DRIVERS DOWNLOAD. Even not found in searching the support drivers on creative labs.

    I've bought a Focusrite Saffire 6 USB, and find drivers is very easy. Just enter Google these keywords "focusrite saffire 6 usb drivers download" and the first link is the good !!!! If I search directly on the Focusrite site, it's also very easy. Focusrite = good support, creative labs = bad support Why ? I don't know but it's very annoying for customers.

  7. #7

    Re: I will never buy EMU products again

    Well,

    support is tragic at CP indeed. Anyway, thanks for link but drivers didn't do a thing. Still after couple of phrases or from the beginning sound goes crazy. I run Vista. I'll try it on other computer with XP, maybe it'll work but I'm tired of searching right settings, system, drivers for EMU 0404 USB, it's just disastrous investment. I'll check deeply another time when I consider buying another audio interface, for sure it won't be Creative Pro one...

  8. #8
    Uber Guru
    Join Date
    Mar 2005
    Posts
    3,887

    Re: I will never buy EMU products again

    Quote Originally Posted by slawek View Post
    Well,

    support is tragic at CP indeed. Anyway, thanks for link but drivers didn't do a thing. Still after couple of phrases or from the beginning sound goes crazy. I run Vista. I'll try it on other computer with XP, maybe it'll work but I'm tired of searching right settings, system, drivers for EMU 0404 USB, it's just disastrous investment. I'll check deeply another time when I consider buying another audio interface, for sure it won't be Creative Pro one...
    Remember check if your system is ready for audio streaming.

    http://www.resplendence.com/latencymon
    http://www.thesycon.de/deu/latency_check.shtml (XP compatible)

    Check also if these optimization articles helps in your case:

    http://www.focusrite.com/answerbase/...gory.php?id=30

    jutapa

  9. #9

    Re: I will never buy EMU products again

    Ok,

    so encouraged one more time and having hope that EMU 0404 would ever work properly I have upgraded my XP and Vista to Win7 x64, bought additional 1 GB RAM up to 4GB now, have clear system now, no flaws, firewalls and wireless net disabled, I optimized it for audio as suggested, my latency is so low in the system as it was never before, Latency program shows that I can use real time audio with no problems, and it;s all for nothing... After using EMU 0404USB instead of Win drivers and simple audio card the magic starts...

    With XP, Vista, Win 7 and programs like Cubase, Audacity, Winamp --> there is no problem at all with any using of audio,

    With XP, Vista x32, Win7 x64 after choosing EMU as my audio system, my projects in Cubase can never be played from the beggining till the end, because there is unpredicted scratches (even that latency is very low) or simply the sound stops playing and you have to reset EMU 0404 USB to work for additional 20-60 seconds until another failure comes, when I try to open winamp with opened Cubase (must use it sometimes to record in Cubase with running Winamp) the magic starts again.. the Winamp... doesn't work at all! You just can't use them both (you can without EMU).

    So I run over 3 systems, spent additional money to optimize my RAM and audio to its best, but unfortunately the EMU wasted all of my efforts. It's totally unworkable and nerves costing audio equipment (at least with Windows) and absolutely my worst purchase ever within couple of thousands transactions, and you can't even find proper drivers without forum help.

    I'd like to have my money back asap and get something professional...
    Last edited by Colin-CL; 11-29-2011 at 03:36 PM.

  10. #10

    Re: I will never buy EMU products again

    Exactly the same issues here with a 0204...

    "my projects in Cubase can never be played from the beggining till the end, because there is unpredicted scratches (even that latency is very low) or simply the sound stops playing and you have to reset EMU 0404 USB to work for additional 20-60 seconds until another failure comes, when I try to open winamp with opened Cubase (must use it sometimes to record in Cubase with running Winamp) the magic starts again.. the Winamp... doesn't work at all! You just can't use them both (you can without EMU)"

    Yep, it's the same for me but I use a 0204, Ableton and foobar2000, really annoying...
    I tried too every single configuration but nothing works properly. =(

    I think I'll try in the next days a generic driver like Asio4all, it would be more likely to work, maybe...

    What's your rig ?
    Do you run an amd chip ?
    We're surely not the only ones to have these issues but it seems to work for most.

    (Sorry for my english, by the way)

    Have a nice day

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •