Results 1 to 3 of 3

Thread: Re: X-Fi web Update install programs

  1. #1

    Unhappy Re: X-Fi web Update install programs

    , Hi all & is help out there. I've an X-Fi extreme Gamer that's worked forever and still does. MY input here is that having upgraded to win7 pro 64bit NONE of the Creative Labs install files work. Much brain bashing,manual extraction of self extract files and running setup still comes up with an error message of [-5004 0x5] which appears to be a runtime error, details suggest something to do with the setup.dll but i can't be sure. i managed to get the card to work by xtracting drivers only and letting windows do the walking but really I want the associated applets(console launcher,wavestudio,etc. E-MAil Support ended up fobbing me off with Oh yours is OEM,go back to computer maker (Mesh) despite fact i have Original Creative install CD which also does not work.
    Any know how to get these things installed. Creative keep saying everything works in Win 64 when,(certainly on my m/c) they don't

  2. #2
    Whiz Kid
    Join Date
    Dec 2007
    Posts
    5,276

    Re: X-Fi web Update install programs

    Hello Dzzr,

    Did your X-Fi Xtreme Gamer card came pre-installed with your computer?
    OEM cards are usually customized by the computer manufacturer, driver and software updates if any, are usually provided by them. Drivers/updates in the download section are intended for retail cards.

    Note that the installation cd was probably released before Win 7 came into the picture.

  3. #3

    Re: X-Fi web Update install programs

    Yes it did, this card also came with Creatives Own software and driver installation CD. drivers and software have been updated from creative as available and have all worked from Vista through to win7 32bit. I now run win 7 pro 64bit and as above nothing from creative will install despite them saying their software is compatable with win 7 including 64bit. SOme of the progs dont even get to the select language screen before halting with the same error. i've tried clean boot, complete removal of all references to creative software and drivers that i can find. the only way back from that one was to use sys restore. Attached is the error screen i get with all the install files, this one is during the SBXF_PCDRV_XPVT_LB_2_18_0015.exe file error..
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •