Results 1 to 8 of 8

Thread: Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

  1. #1

    Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

    Hi there,

    I have had my x-fi titanium for a few years now and it has never really worked properly with windows 7. Originally I used it with win xp and all the software installed no problem. Since moving to win 7 I have never been able to install the driver software fully, I would always get error messages when installing (I-001) and the installation would never complete. I can't use console (or any of the other software) as I get a message which says "There are no supported audio device available".

    The point is though the sound did work so I just left well alone. However this week I wanted to use the mic on my Astro a40 headset. I need to plug the mic jack into the "line in" connection. I think I am then meant to use the console software to change the "line in" to "microphone". However I can't do that as I can't run the software!!

    No matter what I do I can't fully uninstall the Creative software. Even if I use iobit or ccleaner and get rid of anything to do with creative I still can't fully uninstall the driver. So when I try and install the 0008 or 0008c beta driver I still get the same error messages on install. So, right now I am back to square 1, the drivers appear to be installed although I can't use any of the software and I can't uninstall it or install new drivers and I still can't use the mic.

    Help!!!!! I don't know what to do next. Any help would be much appreciated.

  2. #2
    Trusted Contributor
    Join Date
    Aug 2008
    Posts
    87

    Re: Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

    When I first got the same card for Win 7 i used Daniel K's intsalltion CD for Win 7 and everything worked perfectly. Not exactly sure which thread it is in now, but look around for it. Uninstall everything Creatibve you have now, run the CD install, and then use the autoupdate.

    I am pretty sure this is what I used as I remember it was 4 items to download:

    http://forums.creative.com/showthread.php?t=556425

    Run theis and then do the autoupdate.
    Last edited by davevt31; 04-12-2012 at 04:29 AM.

  3. #3

    Re: Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

    Thanks davevt31, I will be giving this a try. However how do I uninstall the current drivers? When I use usual methods the original creative drivers are definitely still there, but I can't 'see' them when I try to 'add or remove' programs. So I would not be getting a 'clean' install.

    Any recommendations?

  4. #4
    Trusted Contributor
    Join Date
    Aug 2008
    Posts
    87

    Re: Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

    With Windows 7 I have never had any issues using the Programs and Features for uninstalling. Uninstall everything that has creative or anything close in the title. Windows may put back some Generic drivers, don't worry about them too much.

    Once you make the CD from the download you can also use the built in "Brute" uninstaller, it will be located aon the CD in the Audio folder > Drivers > Support. There are two folders in here onfor 32 bit the other for 64 bit. Which ever you are running go into that folder and run the Ctzapx program and you can do a final uninstall of all stuff from here to get any leftover files that the Windows Uninstaller may have missed.

  5. #5

    Re: Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

    ahhhh, trying to download these now and part 4 is nowhere to be seen. Links broken and can't seem to get via google. Any ideas?

  6. #6
    Trusted Contributor
    Join Date
    Aug 2008
    Posts
    87

    Re: Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

    Might want to give Creative Support a call and ask for an installation CD that works with Win 7.

    Check out here for info too:

    http://nomoregoatsoup.wordpress.com/

  7. #7

    Re: Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

    This thread is a little old but...

    To the OP: You don't install and uninstall drivers thru "Add/Remove Programs." You do it through the Device Manager.

  8. #8

    Re: Windows 7, my SB X-Fi Titanium Fatal1ty Pro and using a mic

    I have the same card and have had issues with Windows 7 as well. I was always able to muscle through and use the Creative drivers on their site as they became more updated but there would always be some little issue to deal with. With their latest drivers everything worked pretty much fine but switching between game mode and entertainment mode would leave things a bit unhinged.

    Anyway, I recently switched over to Daniel_K's driver set and things have been golden ever since. He also includes several utilities not readily available with the driver software anymore so my recommendation is to just use this set linked here http://forums.creative.com/showthread.php?t=587995

    If you want to remove all drivers first, I would suggest uninstalling all the creative software/drivers thru your control panel (programs and features) and then use "Driver Sweeper" 3.2 which can be downloaded from http://phyxion.net/Downloads/ . I use it with my Creative drivers every time I uninstall to make sure it all goes away. You know things are good when after using the Driver Sweeper and rebooting you will get no sound whatsoever and your speaker icon is either gone or has a block sign thru it. At that point just do the install of the drivers and software (Daniel_K's in the link or the official version on the site... whichever is your preference).
    Last edited by Axis77; 07-24-2012 at 09:22 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •