Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Sound Blaster X7 - Firmware Update (23 Sep 2015)

  1. #1
    Moderator JL-CL's Avatar
    Join Date
    Sep 2014
    Posts
    394

    Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Please be informed that there is a latest firmware update available for Sound Blaster X7. You are strongly advised to install this firmware if you have not done so.

    X7_firmware_win.jpgX7_firmware_mac.jpg

    Here's a new feature:
    - Increase standby duration to 72 hours before entering suspend mode (Power LED off)

    Here are the latest fixes:
    - Intermittent firmware upgrade failure
    - Auto shutdown during audio playback from Line In/Optical In
    - Intermittent noise from Line In left channel
    - USB Host compatibilty with Sony Xperia Z Ultra, Sony Xperia Z3 and XiaoMi Mi3
    - Left channel audio break when calibration of speaker distance is set below 2.2m
    - Inaudible Bluetooth audio after streaming audio via USB Host for more than 30 minutes
    - Bluetooth LED not blinking in pairing mode if there is an existing connected device
    - Inaudible Bluetooth audio when pairing to a second device
    - Unable to connect to a second Bluetooth device if an existing connected device has been streaming for more than 30 minutes
    - Headphones not detected when first inserted
    - X7 Control app running on iOS 9 unable to connect to Sound Blaster X7
    Last edited by JL-CL; 10-01-2015 at 11:25 PM. Reason: grammar
    Cheers,
    JL

  2. #2
    Trusted Contributor
    Join Date
    Nov 2006
    Posts
    159

    Re: Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Hi JL,

    Just performed the firmware update, but it appears to have bricked the X7.

    The software completed with the message 'Device [null] has been successfully updated', but the X7 is now not powering up. I've tried the obvious (leaving it unplugged for a little while) but nada.

    Any ideas?

  3. #3
    Moderator JL-CL's Avatar
    Join Date
    Sep 2014
    Posts
    394

    Re: Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Hi Gatecrasher,

    Did you follow these steps exactly as instructed after the firmware has been updated successfully?

    1) Shut down your device by pressing the Power button (LED off).
    2) Switch off the main power supply to the power adapter and unplug the power cable from your device.
    3) After 10 seconds, plug the power cable back into your device and switch on the main power supply.
    4) Turn your device back on by pressing the Power button (LED on).

    By the way, are you installing the Windows or the Mac version?
    Last edited by JL-CL; 10-01-2015 at 11:38 PM.
    Cheers,
    JL

  4. #4
    Trusted Contributor
    Join Date
    Nov 2006
    Posts
    159

    Re: Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Hi JL,

    Yes, those are the exact steps I've followed. Even left the device unplugged overnight since, but it's completely dead.

    I'm using the Mac / OSX version.

    Cheers,
    Danielle

  5. #5
    Moderator JL-CL's Avatar
    Join Date
    Sep 2014
    Posts
    394

    Re: Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Hi Danielle,

    Please try the following procedures:

    - At standalone, hold the Power button and then plug in the DC power source to the Sound Blaster X7 until all 3 LEDs (Power, Dolby & SBX ) light up simultaneously. This will force the device into bootloader mode. Release the Power button but leave the DC power connected.

    - Connect the Sound Blaster X7 to your Mac system via USB

    - Repeat the firmware steps as instructed.

    Let me know if this approach works for you.
    Last edited by JL-CL; 10-15-2015 at 06:47 PM.
    Cheers,
    JL

  6. #6

    Re: Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Hi after update with the latest firmware. it was updated successfully but after less than 2 week of use my unit bricked as well. Bootloader mode also didn't work.

  7. #7

    Re: Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Nvm found that the power adaptor had burn out.

  8. #8
    Trusted Contributor
    Join Date
    Nov 2006
    Posts
    159

    Re: Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Hey JL,

    That returned my device from the dead, many thanks

  9. #9
    Moderator JL-CL's Avatar
    Join Date
    Sep 2014
    Posts
    394

    Re: Sound Blaster X7 - Firmware Update (23 Sep 2015)

    Quote Originally Posted by soulerjk View Post
    Nvm found that the power adaptor had burn out.
    To avoid frequently "hot-plugging", connect the power adapter to the Sound Blaster X7 before switching ON the AC mains.
    Last edited by JL-CL; 10-16-2015 at 11:52 AM. Reason: spelling
    Cheers,
    JL

  10. #10
    1
    Last edited by omni_gamer; 11-03-2016 at 02:36 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •