Page 5 of 5 FirstFirst ... 3 4 5
Results 41 to 46 of 46

Thread: SB X-Fi Series Support Pack 3.8 SE (10/22/2015) - UAA for PCI / alternate driver for SB077x

  1. #41

    Re: SB X-Fi Series Support Pack 3.8 SE (10/22/2015) - UAA for PCI / alternate driver for SB077x

    Could someone help me with the installation? I have Windows 10 x64 Pro and a Sound Blaster X-Fi Titanium Fatal1ty Champion Series. I cannot get the install to start. I downloaded the "XFI_SupportPack_3_8_SE.exe" and it will not install.

    *edit*
    Ignore my question. Just saw that this is for PCI.
    Attached Images Attached Images
    Last edited by TheOne320; 02-19-2016 at 03:09 AM.

  2. #42
    Contributor
    Join Date
    Sep 2015
    Posts
    11

    Re: SB X-Fi Series Support Pack 3.8 SE (10/22/2015) - UAA for PCI / alternate driver for SB077x

    Quote Originally Posted by N3k0 View Post
    I have a huge problem. I remember when I first installed Windows 10 I had to use a troubleshooter to hide updates that Daniel K gave me to prevent some Creative updates from installing before I actually install this support pack. It helped but now a big Windows 10 update occured and everything is back again D': I got no real sounds. I uninstalled the Support Pack but Windows 10 IMMEDIATLY downloads new automatic updates for my sound devices. Then the sound works, but as soon as I turn the volume up I get horrible feedback sound (like when you move a microphone to a speaker). It kills my ears. How can I fix this?

    Also when I plug in my TV via HDMI cable, it automatically switches to the HD Audiodevice of my TV and my computer sounds then works perfectly fine through the TV. This never happened before when I used TV + normal screen at the same time. My computer sound was always superior. Not anymore. I tried reinstalling multiple Support packs everytime. When I enter the Console Launcher it says "No supported devices detected". I don't get it. Which support pack will work? The 3.5 pack always worked fine for me but now that does not even work. It's all because of this big update...it always install new crap as soon as I uninstall drivers.
    do a clean install following the next steps:

    1. disable your internet connection (so windows won't download the driver).
    2. uninstall all the drivers and all the software related to X-Fi using the control panel (including alchemy, creative software updater and openAl).
    3. reboot the pc and if there is left a driver for the X-Fi in the device manager uninstall it using the right button of the mouse and selecting "also uninstall related software" (sorry but i have the spanish version of windows, maybe it is written different in english), reboot the pc. If your windows has several driver backups then you will have to repeat this step until there is only a yellow mark indicating unknown multimedia device (or something like that).
    4. reinstall using one of daniel_K packs (3.8 SE ---> UAA mode | 3.8 ---> WDM mode)
    5. reconnect to the internet.

  3. #43

    Re: SB X-Fi Series Support Pack 3.8 SE (10/22/2015) - UAA for PCI / alternate driver for SB077x

    I recently built a new system running Windows 10 Pro 64 Bit and installed my X-Fi Elite Pro (which I have owned for many years). I installed the X-Fi Support Pack 3.8 SE andall sound card functions worked perfectly. I then encountered some issues related to Windows 10 and needed to reinstall the operating system. Upon completion of that, I installed the X-Fi Support Pack 3.8 SE and now thereis no option to choose “Use Built In Decoder” in the Audio Control Panel. There also is no Decoder tab there. When I switch to Entertainment Mode, there also are no choices for DTS/Dolby. All of those items were thereafter my first Windows 10 installation. I did uninstall and reinstall the Support Pack but still no DTS/Dolby. All other features on the card seem to be fine. Anyone have any advice as to why I have lost this feature andhow to repair it? Thanks.

  4. #44

    Re: SB X-Fi Series Support Pack 3.8 SE (10/22/2015) - UAA for PCI / alternate driver for SB077x

    hi I am trying to install the new audio console since it doesn save my settings each time i restart. It says setup has experience an error. close program and others. If I launch the setup it says setup unable to detect a supported product... I am having a X-Fi Fatal1ty FPS version. Am on Win7 Ultimate


    IF there anyway just to make my setting stick without installing the whole driver and others?

    Please help.

    Thanks.
    Last edited by firstknight; 08-07-2016 at 01:44 PM.

  5. #45
    Contributor
    Join Date
    Mar 2006
    Posts
    19

    Re: SB X-Fi Series Support Pack 3.8 SE (10/22/2015) - UAA for PCI / alternate driver for SB077x

    How well does this package work for a X-FI Platinum PCI on Windows & SP1 64 bit?
    Any feedback would be greatly appreciated.

  6. #46
    Contributor
    Join Date
    Mar 2006
    Posts
    19

    Re: SB X-Fi Series Support Pack 3.8 SE (10/22/2015) - UAA for PCI / alternate driver for SB077x

    Well, 3.8 SE works on Windows 7 64 bit- only issue is Mode Switcher is sluggish.
    Appreciate Daniel doing such work.
    No decent PCI-E soundcaeds out there so I'm glad I can still use my old PCI.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •