Results 1 to 10 of 10

Thread: iRoar speaker connection messing up

  1. #1

    iRoar speaker connection messing up

    I've had my Creative iRoar speaker for a few months, and I've loved it for the most part. But recently, the sound seems to be going in and out. I can't tell if it's the connection, or if the sound is messing up. At first it seemed to be an issue with the Bluetooth connection, so I started using it with the USB cord on my computer - and now that's messing up too. The speaker will abruptly go in and out while playing. I don't think the speakers would be blown out either, I never blast it at the loudest volume or anything. Any troubleshooting recommendations?

  2. #2
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    814

    Re: iRoar speaker connection messing up

    Quote Originally Posted by weketchum View Post
    I've had my Creative iRoar speaker for a few months, and I've loved it for the most part. But recently, the sound seems to be going in and out. I can't tell if it's the connection, or if the sound is messing up. At first it seemed to be an issue with the Bluetooth connection, so I started using it with the USB cord on my computer - and now that's messing up too. The speaker will abruptly go in and out while playing. I don't think the speakers would be blown out either, I never blast it at the loudest volume or anything. Any troubleshooting recommendations?
    Hi weketchum,

    You may want to try a hardware reset.
    Cheers,
    HT-CL

    http://www1.wfp.org/

  3. #3

    Re: iRoar speaker connection messing up

    Quote Originally Posted by HT-CL View Post
    Hi weketchum,

    You may want to try a hardware reset.
    How is that done?

  4. #4
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    814

    Re: iRoar speaker connection messing up

    Quote Originally Posted by weketchum View Post
    How is that done?
    Hi weketchum,

    You can read about how to do a hardware reset on the Creative iRoar here.
    Cheers,
    HT-CL

    http://www1.wfp.org/

  5. #5

    Re: iRoar speaker connection messing up

    While the reset works to fix it, this issue still repeatedly comes up. Are there any ideas for a permanent fix, as opposed to just having to reset it all the time?

  6. #6
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    814

    Re: iRoar speaker connection messing up

    Quote Originally Posted by weketchum View Post
    While the reset works to fix it, this issue still repeatedly comes up. Are there any ideas for a permanent fix, as opposed to just having to reset it all the time?
    Hi weketchum,

    You may want to try to install the latest firmware to the Creative iRoar. You can do so by installing the Creative iRoar software for the computer and use the software to update the firmware of the speaker.

    Before you update the firmware of the speaker, connect the speaker directly to a USB port of the computer instead of connecting to a USB hub.

    Installing the firmware while the speaker is connected to a USB hub may cause the firmware update to fail.
    Cheers,
    HT-CL

    http://www1.wfp.org/

  7. #7

    Re: iRoar speaker connection messing up

    Quote Originally Posted by HT-CL View Post
    Hi weketchum,

    You may want to try to install the latest firmware to the Creative iRoar. You can do so by installing the Creative iRoar software for the computer and use the software to update the firmware of the speaker.

    Before you update the firmware of the speaker, connect the speaker directly to a USB port of the computer instead of connecting to a USB hub.

    Installing the firmware while the speaker is connected to a USB hub may cause the firmware update to fail.
    Hello! So I've attempted to update the firmware, but it doesn't look like it's working. I downloaded the iRoar Dashboard app, connected the speaker to the computer via USB, went to Settings, and updated the firmware. Outside of the app, it says the firmware was updated. But when I open the iRoar Dashboard again, it still says that the firmware needs to be updated. Any idea what's going on here?

  8. #8
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    814

    Re: iRoar speaker connection messing up

    Quote Originally Posted by weketchum View Post
    Hello! So I've attempted to update the firmware, but it doesn't look like it's working. I downloaded the iRoar Dashboard app, connected the speaker to the computer via USB, went to Settings, and updated the firmware. Outside of the app, it says the firmware was updated. But when I open the iRoar Dashboard again, it still says that the firmware needs to be updated. Any idea what's going on here?
    Hi weketchum,

    I own the Creative iRoar and the iRoar Dashboard did not say that the firmware needs to be updated after the firmware had been updated.

    You may want to try to update the firmware using the USB connection again to see if the iRoar Dashboard software states that the firmware needs to be updated again.

    Does the volume of the Creative iRoar go in and out after the firmware update?
    Last edited by HT-CL; 04-20-2017 at 03:39 PM.
    Cheers,
    HT-CL

    http://www1.wfp.org/

  9. #9

    Re: iRoar speaker connection messing up

    Quote Originally Posted by HT-CL View Post
    Hi weketchum,

    I own the Creative iRoar and the iRoar Dashboard did not say that the firmware needs to be updated after the firmware had been updated.

    You may want to try to update the firmware using the USB connection again to see if the iRoar Dashboard software states that the firmware needs to be updated again.

    Does the volume of the Creative iRoar go in and out after the firmware update?
    I just ended up updating via Bluetooth, with the app on my iPhone. Hopefully this improves the situation as a whole.

  10. #10
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    814

    Re: iRoar speaker connection messing up

    Quote Originally Posted by weketchum View Post
    I just ended up updating via Bluetooth, with the app on my iPhone. Hopefully this improves the situation as a whole.
    Hi weketchum,

    I hope that the problem will be resolved after the firmware update.

    Thank you for the information.
    Cheers,
    HT-CL

    http://www1.wfp.org/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •