Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18

Thread: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

  1. #11
    Contributor Ashanvale's Avatar
    Join Date
    Apr 2015
    Location
    Turkey
    Posts
    19

    Re: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

    hi i tryed in windows 7 sp1 also with 2 version offical drivers and win 8.1 drivers;

    older one giving no sound and bluescreen disabling Xram on registry solving bsod but leaving me again with no sound on any of the card output. while other 2 is with sound and showing the openal device exsist on alcaps (both 32 and 64bit) but
    while in the game giving only software just paning the sound left and right.

    XFTI_PCDRV_L11_2_40_0008.exe
    XFTI_PCDRV_LB_2_17_0008.exe
    XFTI_PCDRV_LB_2_17_0007.exe

    btw when i plug my audigy2nx usb sound card its just working openal (sens_oal) right
    same game win10 64bit with positional audio i can clearly hear.

    for 3.8 with titanim fatal1ty pro still same no hardware openAl only paning the sound left and right
    Last edited by Ashanvale; 05-16-2017 at 06:05 PM.

  2. #12
    Trusted Contributor
    Join Date
    Aug 2014
    Location
    Brazil
    Posts
    131

    Re: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

    Look for the driver version 2.17.0008c. It is a beta driver that fixes most BSODs on the Titanium Fatality Pro, sadly newer drivers have problems, especially with OpenAL games.
    You can install the support pack without the driver, and then install the beta driver. I recommend version 3.8, as it is the only one I tested.

  3. #13
    Trusted Contributor
    Join Date
    Nov 2012
    Posts
    109

    Re: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

    I found this:
    "If I remember well, there was a ct_oal.dll (x-fi) missing in the c:\windows\syswow64\ resulting in a card that cannot use hardware mode with x64 applications.

    The solution was to extract the ct_oal.dll from the drivers you install (example :\Drivers\SBXF\wdm\commo n\amd64\ and put it in the c:\windows\System32 folder to fix this problem."

    But first download ALCapsViewer and check.

    magg

  4. #14
    Contributor
    Join Date
    Mar 2006
    Posts
    19

    Re: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

    How well does this Support Pack 4.0 work for a X-Fi Platinum PCI on Windows 7 SP1 64 bit?
    Any feedback would be deeply appreciated.

  5. #15
    Contributor Ashanvale's Avatar
    Join Date
    Apr 2015
    Location
    Turkey
    Posts
    19

    Post Re: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

    okay Here ve go; i return back to windows 10 after i fail on win7, i should use win10 for my new pc anyway; so;

    2.17.0008c + 3.8 --> No Sound
    Last edited by Ashanvale; 05-16-2017 at 06:04 PM.

  6. #16
    Contributor
    Join Date
    Mar 2006
    Posts
    19

    Re: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

    Ashanvale,

    So, with all the data you posted, are you saying Support Pack 4.0 works for you on Windows 10 but not Windows 7 ?

  7. #17
    Contributor Ashanvale's Avatar
    Join Date
    Apr 2015
    Location
    Turkey
    Posts
    19

    Re: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

    didnt tryed support pack 4.0 on win7. but i buyed audigy rx now and situation is same no hardware open Al no ds3d with alchemy... gonna try different games but i can clearly hear from rightmark its emulating it on software

    EDIT:

    Problem solved by removing Wrap_oal.dll on both system32 and sysWOW64 folders.. forcing OpenAL enumerate only to chose X-FI automaticly... theres no wrap_oal.dll so theres no software renderer for openAL to chose.. Hardware and Eax working... (edit on ini file to use OpenAL enumeration ''Devicename= '' didnt have to use alchemy)
    Last edited by Ashanvale; 05-16-2017 at 04:07 PM.

  8. #18
    Contributor Ashanvale's Avatar
    Join Date
    Apr 2015
    Location
    Turkey
    Posts
    19

    Re: *New 2017 D. Kawakami Support Pack 4.0 for X-Fi

    masseffect 1 has some sound problems... drop sound issues ect,..

    probably because X-RAM Automatic Mode (AL_STORAGE _AUTOMATIC) ?

    while masseffect runing 0Mb of x-ram aviable while not 61mb
    Other openal games leaving 30-40mb free from 64mb

    Replacing ct_oal.dll from older drivers didnt work probably this thing is more deep inside the drivers

    there was a lot topics around about this problem
    http://forums.creative.com/showthread.php?t=726283

    Since creative not updating their drivers (maybe they still responsible about broken drivers they release last ?), i hope daniel k will fix this issues about openal on next updates

    İts looks like more gamespesific than general problem, looks like sound buffers not removing themselfs and they cumulate and exceed 128 hardware sound on xfi limitation and after that new sounds wont play properly...this is probably caused by little code bug or line missing for special cases about buffer removal on X-ram or at system memory

    unfortunatly i dont have any knowladge to dig in drivers and find that bug
    Last edited by Ashanvale; 05-17-2017 at 04:08 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •