Results 1 to 2 of 2

Thread: Sound Blaster Omni Mac App Reset After Restart

  1. #1
    Visitor
    Join Date
    Apr 2017
    Location
    Ankara
    Posts
    1

    Unhappy Sound Blaster Omni Mac App Reset After Restart

    Hi Forum,

    I have just bought a Sound Blaster Omni 5.1 for my Mac (El Capitan). It works great except one issue. I use a pair of studio monitor speakers Presonus Eris 4.5 with an Active Subwoofer. I plugged my sub to sub out and speakers to left and right. It works great but i have to check "Bass Redirection" and "Bass Gain" for better subwoofer out in Bass Management.

    It works great until restart. Then it reverts back to it's original state with unselected Bass Redirection and Bass Gain. Every restart i have to check it. App is not saving it's settings somehow.

    Uninstalling and installing again not fixed the problem.
    I am on a Mac Pro with El Capitan installed. (10.11.6). I use latest drivers (SBOM_MAC_L13_1_04_18.dmg)

    Thanks in advance

    01.jpg

    02.jpg
    Last edited by motionworks; 04-19-2017 at 02:41 PM. Reason: Wrong sentence

  2. #2
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    807

    Re: Sound Blaster Omni Mac App Reset After Restart

    Quote Originally Posted by motionworks View Post
    Hi Forum,

    I have just bought a Sound Blaster Omni 5.1 for my Mac (El Capitan). It works great except one issue. I use a pair of studio monitor speakers Presonus Eris 4.5 with an Active Subwoofer. I plugged my sub to sub out and speakers to left and right. It works great but i have to check "Bass Redirection" and "Bass Gain" for better subwoofer out in Bass Management.

    It works great until restart. Then it reverts back to it's original state with unselected Bass Redirection and Bass Gain. Every restart i have to check it. App is not saving it's settings somehow.

    Uninstalling and installing again not fixed the problem.
    I am on a Mac Pro with El Capitan installed. (10.11.6). I use latest drivers (SBOM_MAC_L13_1_04_18.dmg)

    Thanks in advance

    01.jpg

    02.jpg
    Hi motionworks,

    You may want to contact Creative support here.
    Cheers,
    HT-CL

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •