Results 1 to 8 of 8

Thread: Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty

  1. #1

    Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty

    No matter what this card just will not install properly in the Spring Creators Update (build 17133.73 32-bit). Worked just fine in the Fall Creators Update. Have tried a clean install. Installing the latest official drivers as well as using danielk's latest. Nothing works. The Creative apps refuse to detect my card. What gives?

  2. #2
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    1,296

    Re: Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty

    Quote Originally Posted by xiphi View Post
    No matter what this card just will not install properly in the Spring Creators Update (build 17133.73 32-bit). Worked just fine in the Fall Creators Update. Have tried a clean install. Installing the latest official drivers as well as using danielk's latest. Nothing works. The Creative apps refuse to detect my card. What gives?
    Hi xiphi,

    Is the driver provider Creative when you click on "Properties" of the sound card in Device Manager?

    You may want to try to do a manual install of the driver to see if it works.

    This article contains information on how to do a manual install of the driver.
    Last edited by HT-CL; 04-11-2018 at 05:49 PM.
    Om Vajrapani Hum,
    HT-CL

    http://www1.wfp.org/

  3. #3

    Re: Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty

    Yes the driver is by Creative. Version 6.0.240.15. Only output source listed is SPDIF Out. So to be clear, setup detects and installs the apps and driver, but the apps themselves fail to detect the card when I launch them. Since, I'm unable to use Speakers as the output, due to them not being listed as an output source, I have no audio whatsoever.

  4. #4
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    1,296

    Re: Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty

    Quote Originally Posted by xiphi View Post
    Yes the driver is by Creative. Version 6.0.240.15. Only output source listed is SPDIF Out. So to be clear, setup detects and installs the apps and driver, but the apps themselves fail to detect the card when I launch them. Since, I'm unable to use Speakers as the output, due to them not being listed as an output source, I have no audio whatsoever.
    Hi xiphi,

    You may want to use Windows 10 version 1709 for the time being.
    Om Vajrapani Hum,
    HT-CL

    http://www1.wfp.org/

  5. #5
    Super Contributor squall_leonhart's Avatar
    Join Date
    Jan 2010
    Location
    Australia
    Posts
    235

    Re: Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty


  6. #6

    Re: Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty

    Quote Originally Posted by HT-CL View Post
    Hi xiphi,

    You may want to use Windows 10 version 1709 for the time being.
    Thanks. That's what I've done. Though, I did just update to build 17134.1 and the problem still occurs. Will be rolling back to 1709. Hope a fix is found because I really like the update.

  7. #7

    Re: Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty

    Quote Originally Posted by squall_leonhart View Post
    Thanks, but this doesn't apply to my system as I do not have any virtualization features.

  8. #8
    Contributor
    Join Date
    Apr 2011
    Location
    Germany, Munich
    Posts
    15

    Re: Windows 10 Spring Creators Update won't properly install Creative X-Fi Titanium Fatal1ty

    No Problems with my X-Fi Titanium Fatal1ty with FCU. Then inplace update to SCU, no problems.
    But then i removed the fatality to see if my Titnaium HD works now on the Threadripper / Ryzen platform with SCU, but no luck and installeing the Fatality back. Driver installation without any errors, but nothing worked.
    I thought great, now i screwed up 2 soundcards!
    It takes me 3 times of removing and installing the (Daniel K) Driver and now everything works like on FCU.
    Memory integrity was disabled by default.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •