Results 1 to 2 of 2

Thread: Sound BlasterX AE-5 & ASUS ROG Maximus IX Hero

  1. #1

    Sound BlasterX AE-5 & ASUS ROG Maximus IX Hero

    Hello,

    Have any members of the forum got a ‘Sound BlasterX AE-5’ working well in their ‘ASUS ROG Maximus IX Hero’ motherboard with Windows 10 (64-bit)?

    I’ve read the bad experience of ‘bfollowell’ at the thread below which is putting me off buying a ‘Sound BlasterX AE-5’.

    http://forums.creative.com/showthread.php?t=742161

    I’m not prepared to make huge changes to my system/operating system just to get something as simple as a sound card to work!

    Kind regards,

    Glen
    Last edited by GlenV; 05-15-2018 at 01:37 AM.

  2. #2
    Moderator HT-CL's Avatar
    Join Date
    Nov 2014
    Posts
    1,364

    Re: Sound BlasterX AE-5 & ASUS ROG Maximus IX Hero

    Quote Originally Posted by GlenV View Post
    Hello,

    Have any members of the forum got a ‘Sound BlasterX AE-5’ working well in their ‘ASUS ROG Maximus IX Hero’ motherboard with Windows 10 (64-bit)?

    I’ve read the bad experience of ‘bfollowell’ at the thread below which is putting me off buying a ‘Sound BlasterX AE-5’.

    http://forums.creative.com/showthread.php?t=742161

    I’m not prepared to make huge changes to my system/operating system just to get something as simple as a sound card to work!

    Kind regards,

    Glen
    Hi Glen,

    There is an option on the BIOS setting of the ASUS ROG Maximus IX Hero mainboard that can enable "Legacy Boot".

    You can refer to page 63 of the ASUS ROG Maximus IX Hero's BIOS manual.
    Om Vajrapani Hum,
    HT-CL

    http://www1.wfp.org/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •